Upgraded Rancher 1.6.18 --> 1.6.22 errors :(


#1

Hi,

We tried to upgarde our rancher environment from 1.6.18 to 1.6.22.
The steps we did was
.1 stop current
2. download new one
3. restart with new image.
4. logged into GUI

went to GUI looks good but now ALL Infrastructure Stack say unhealthy
for
healthcheck
ipsec
newtwork services
schedulrer,

I tried to click on “upgrade” them but goes into loop and nothing happens and our “HOSTS” can’t connect.

we are using CentOS 7 with docker “Docker version 18.06.1-ce, build e68fc7a”

I’m new to rancher , what are some troubleshooting tips I can look into ? etc… where might the log files be ?

Thanks
jk


#2

BTW, I resolved the issue. The Rancher clients couldn’t reconnect because of “error” in PROXY settings. Once PROXY settings were correct on client HOSTS they were able to reconnect to SERVER and Rancher began to operate properly after upgrade.

MODERATOR_ please close.

thanks


#3

hi can you put more specific details on what you did to resolve here?