virt-install errors when running as regular user


I need some help and guidance from you regarding this virt-install issue I am seeing.

OS : SuseEnterpriseLinuxServer (SLES) 12 Service Pack 1 virt-install version on the box virtual@SLES12-bare:~> virt-install --version 1.2.1 libvirt version : libvirt-1.3.4-565.1.x86_64

What I tried:

I tried to start virt-install as regular user and I am seeing errors listed below.

If I start the same with sudo it works (the user virtual shown here is a sudo enabled user)

I really want to start the virt-install as a regular user.

Please help.


[QUOTE]virtual@SLES12-bare:~> virt-install --connect qemu:///session -n SLES12_SP1 --memory 4096 --vcpus 2 --cdrom /data/ADP_x86_64_SLES12SP1.x86_64-12.1.6.preload.iso --graphics spice --disk /data/kvm_images/SLES12_SP1.img
WARNING Graphics requested but DISPLAY is not set. Not running virt-viewer.
WARNING No console to launch for the guest, defaulting to --wait -1

Starting install…
ERROR Failed to connect socket to ‘/run/user/500/libvirt/virtlogd-sock’: No such file or directory
Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
virsh --connect qemu:///session start SLES12_SP1
otherwise, please restart your installation.

Thank You for your time and attention.

You need to create a user session first…

virt-manager --connect qemu:///session

This should then add a user session to run/create vm’s (files would be down in ~/.local/libvirt) I use softlinks to my vm storage device pool.

Then I use for example;

virt-install --connect qemu:///session -n SLES12_SP1 --memory 4096 --vcpus 2 --cdrom /repositories/iso_images/SLE-12-SP1-Server-DVD-x86_64-GM-DVD1.iso --graphics spice --disk ~/.local/libvirt/images/sled12sp1.qcow2

This all assumes you have the libvirtd service started…

Thank you for your answer Malcomlewis.

I can’t run virt-manager for two reason.

  1. I don’t have X on the machine, so I will have to run it remotely or ‘X’ it back and I don’t have a machine for that.
  2. virt-manager is not a requirement is my understanding to running virt-install.

But you do bring up a valid point and may be I need to do a virus connect and try.

I will try that.

Thank You

Ahh ok, then run;

virsh --connect qemu:///session

AFAIK, once you have a session created all should be good as your user.