Virtualizing Groupwise 2012 Server (Hyper-V)

We have a Groupwise 2012 Server that we want to get the Hardware so we virtualized the drives to a Hyper-V VHD.

I used this video tutorial to use “dd” to clone the drive(s)

After starting it with Hyper-V, however, it says: "waiting for drive /dev/disk/by-id/-part3… and fails.

So, I determined it needed the drive(s) set in fstab or something. So, I looked at the old Groupwise Server and saw that the drives are listed under: /dev/cciss/

When the boot fails in the hyper-v area, I went to /dev and there are no drives listed. Nothing for sda (or b) no hda (or b) no /dev/cciss

So, all reference to drives is not there. Do I need to create some files? (like: touch /dev/sda) or something?

I know that the VHD files are:
Part 1: /boot
Part 2: /swap
Part 3: / (main one)

Second drive:
Part 1: /home

When it boots, it looks to me like it sees the ATA drives but again, no way of seeing the drives listed in /dev, they don’t auto-populate or anything in /dev

I tried mounting the VHD file on my computer using “EXT2 Volume Manager” and modify the fstab, etc but again, nothing in the /dev folder so I don’t know what to do.

Any ideas?

Hi Tomnibus,

When the boot fails in the hyper-v area, I went to /dev and there are no drives listed. Nothing for sda (or b) no hda (or b) no /dev/cciss

what OS is the GW Server running? “cat /etc/SuSE-release” should give the details.

Does anything show up when calling “lsscsi”? And what’s in /var/log/messages, especially during boot?

Could you dive a short summary of what disks/partitions you cloned via “dd” - full disks, partitions, and “all disks/partitions” or only some? Are all virtual images attached to the VM?

As you’re booting some disk image in Hyper-V, is that from the clone of the GW install? Or is this some pre-defined SLES image?


Unfortunately, I can only do a screen capture of the last bit because I don’t have any ablity to get further into the OS. There is no SuSE-release file because I never get the actual “/” partition to load. But, logging into the physical server it says it’s: SUSE Linux Enterprise Server 11 (x86_64) version 11, patch level 2

The lsscsi command says “Command not found” because I don’t actually have anything booted.

I cloned all the partitions. As mentioned above, the first disk had three partitions and I copied them all. The DD command I used was: sudo dd if=/dev/cciss/c0d0 of=/mnt/image/groupwise1.img (the mount location on the smb share). The second command and second disk was just /dev/cciss/c0d1

all virtual images are attached to the VM.

When I’m booting in Hyper-V, I’m using the groupwise1.img file that I converted to a VHD and I have the groupwise2.img (vhd) as the secondary drive on the system. Partition 3 on the groupwise1.vhd file is the / mount point which should contain everything.

Screenshot of what my GW boot screen looks like.

Hi Tomnibus,

ok, I get the situation - your still in the initrd phase, where the boot system is trying to locate the root fs.

I cloned all the partitions. […]
Per the commands you cited, you have created two disk images (instead of an image per partition - which would not have been helpful)

all virtual images are attached to the VM.

So your VM has two virtual disks now. But what catches the eye is that your VM doesn’t report these during boot, according to your screen shot - it recognizes the virtual CDROM, but explicitly ignores ATA devices. Do you have the choice to add the virtual disks as SCSI disks, rather than as ATA disks?


PS: As you probably can tell, I’ve not yet worked with Hyper-V personally, but many of the hypervisor features and requirements are similar across the different families (Xen, VMware, Hyper-V,…)

Hi Tomnibus,

I had a look at a SLES11SP3 install, where there is a hyper-v package containing required tools - probably something similar is available on SLES11SP2? If so, did you install that on the physical machine and made sure “mkinitrd” was called, to prepare an initial ram disk with the required drivers?


I do have an option to configure the devices as SCSI devices and when I try that Hyper-V complains there is a non-system boot disk.

It must somehow be seeing the ATA because it boots from it.

Someone else on another forum suggested booting from the SLES CD and doing a repair. I got nothing to lose so I’m looking at doing that.

No, I didn’t. Perhaps I need to do that. Not sure how to do that, though.

I know enough about linux to administer but this stuff with boot up, etc is not my forte.

Not sure how to do that, though.

It could look like the following:

[CODE]# zypper search hyper
[FONT=monospace][COLOR=#000000]Refreshing service ‘updatechannelsles11sp3’. [/COLOR]
Loading repository data…
Reading installed packages…

S | Name | Summary | Type
| hyper-v | Microsoft Hyper-V tools | package
| hyper-v | Microsoft Hyper-V tools | srcpackage
| slessp3-hyper-v | Recommended update for hyper-v | patch

zypper install hyper-v



You’d then have to recreate the disk image containing the /boot partition.

YMMV :wink:



I booted from the SLES 11 boot CD (made it into an ISO) and repaired the system. It did checks on the drives and re-created the fstab for me and it booted.

I did do the installation of hyper-v and mkinitrd above and restarted after it came online. It is running nicely.

Thanks for your help!

Hi Tomnibus,

thank you for reporting back your success, it’s always nice to see that issues got resolved :slight_smile: