vSphere Cloud Provider - Password not saved?


i was trying to get the vsphere volume cloud provider working but i am not able to get it working - do i miss something?

I think my biggest Problem is that the GUI Yaml-Editor discards the “password” Option when i hit save?


  • Rancher 2.3.2
  • vCenter/ESXi 6.7

My Settings in the Cluster-Yaml:

    name: vsphere
      disk: {}
        insecure-flag: true
        soap-roundtrip-count: 0 
      network: {}
          datacenters: Datacenter-KOE
          port: '443'
          soap-roundtrip-count: 0
          user: rancher-api@vsphere.local
          **--> When i enter "password: mypassword" here and hit "save" it is deleted?**
        datacenter: Datacenter-KOE
        default-datastore: RAID-10-SAS
        folder: ranchervols


Hi Kai

The password is not discarded, I’ve seen this on previous versions of Rancher also. I’d imagine the password gets stored as a secret or something to that effect on Rancher. If it’s not working then something else is wrong with your config. First think I can pick up is that the folder should include “vm/” before the folder name. In our environment it’s like the below:

folder: “vm/Rancher”

Rancher would be the VM folder directly under the DC object in vCenter.

1 Like

Hi @TheNightHawk

Jesus - you are absolutly right, the “vm/” was the key. I hope Rancher will update the documentation regarding the password, the folder-parameter and the general notation because it is a little bit confusing!

Thank you!