11 SP3 repos not getting added after successful registration

In VMWare workstation 10, I just installed a fresh copy of SLED 11 SP3 64-bit & successfully registered it, but none of the repos have been added. I only have these:

| Alias | Name | Enabled | Refresh | Type

1 | SUSE-Linux-Enterprise-Desktop-11-SP3 11.3.3-1.95 | SUSE-Linux-Enterprise-Desktop-11-SP3 11.3.3-1.95 | Yes | No | yast2
2 | nVidia-Driver-SLE11-SP3 | nVidia-Driver-SLE11-SP3 | Yes | Yes | rpm-md

When I log into the customer center, my system doesn’t show up. So I registered again & it still said it was successful, but still doesn’t show up in the customer center nor do any of the repos get added.

This is the command I used to register:

suse_register -a regcode-sled=` -a email= -a moniker= -L /root/.suse_register.log

I checked the log & saw some errors about the nvidia repo but the results were a success & the message said no errors.

Is anyone else having this problem?



Did you check in SCC?

It may take a little while to register, force a refresh and they should
show up;

zypper ref --force

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Hi Malcolm,

Thanks for the link. I checked it & didn’t see it there either. Hopefully it’ll show up soon.

I ran the zypper ref --force command, but there was still no change.

I found your thread about a similar issue & followed your directions to the mirror credentials & manually added the SLE-11 SP3 links. I now have these repos:

| Alias | Name | Enabled | Refresh

1 | SMT_Pool | SMT Pool | Yes | Yes
2 | SMT_Updates | SMT Updates | Yes | Yes
3 | SUSE-Linux-Enterprise-Desktop-11-SP3 11.3.3-1.95 | SUSE-Linux-Enterprise-Desktop-11-SP3 11.3.3-1.95 | Yes | Yes
4 | Security_Module | Security Module | Yes | Yes
5 | nVidia-Driver-SLE11-SP3 | nVidia-Driver-SLE11-SP3 | Yes | Yes

But even though they’re in there, the system still thinks there are no repos. I went to Yast → Online Update Configuration to check & it shows no Current Update Repository selected. When I go to Advanced → Edit Software Repositories, I get a list of them with all with a Priority of 99 (Default). It doesn’t give me an option to pick a repo & set it as default. So I’m still stuck.