cannot register with service center

I just started using an HP workstation loaded with SLED 11 SP2. I want to enable the update repository which requires registration with the novell service center but I am unable to do this. Here’s what I do:

  • From the Yast control centre I run as superuser “Online Update”. A initialization window reports that no update repository configured yet and offers the option of running “configuration workflow”
  • running the “workflow” brings up the “Novell Customer Center Registration” dialog window
  • Using default settings I click Next. This results in “An error occurred wile connecting to the server”, details of which are “ERROR: Failure when receiving data from the peer: (56)”.

I don’t know what to try next. The proxy is set correctly I believe.

Thanks for any help!

If your using a proxy, there are a few things to configure;

Your proxy should should accept Novell domain (or at least selected
sites used like and without

You need to populate proxy setting in YAST and to add two lines
with your proxy information to /etc/profile, for example:

export http_proxy=“
export https_proxy=“

As well as the /root/.curlrc

Then I would login to the NCC web page and delete the system and
re-register it.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 0:40, 2 users, load average: 0.14, 0.10, 0.07
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

Thanks for this - yes it is indeed a proxy problem (I should have worked this out myself). I tried your suggestions but unfortunately we have a web proxy requiring authentication and I gather this makes things difficult. curl now works from the command line but the registration process still fails. I tried setting http_proxy in the form http://username:password@host:port/ and then using the suse_register command line program but still no go (Proxy Access Denied error about 1,000 times!). Is there any way to register through a proxy requiring authentication?


Are there any characters in your username or password that may need to
be escaped?

Another thought since you indicate the command line curl is working, is
to register via the command line;

suse_register -a regcode-sled=YourActivationCode -a email=YourEmailAddress -a moniker=YourHostname -L .suse_register.log

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 9:33, 3 users, load average: 0.03, 0.04, 0.05
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

I have the same problem with SLES11SP2 and have just filed a bug report for suseRegister-1.4-1.24.1. Reason: suseRegister ignores the proxy credentials. When I run suse_register, I get “HTTP/1.1 407 authenticationrequired”.