SLED10 set up the novell Customer Center but cant add update

Hello.I have a HP Mini 2140 pre-installed SLED 10 Linux SP2.I want to get some updates,so I used Novell Customer Center Configruation in Yast 2.I solved the problem about the cert,but there is another question.It said that cannot add any update server.Why?How can I solve this?Does software update still spport sled 10 sp2?How do I get updates?Thanks!

Support for SLED 10 SP2 ended years ago. Perhaps whichever update repo the machine is trying to add as an update has been removed due to obsolescence. The latest version of SLED 10 is SP4 but that is also no longer supported.

Assuming you still have a valid SLED subscription, you could try installing the current version of SLED, which is SLED 11 SP3. It can be downloaded from
You only need DVD1.

Thanks.But my computer had been pre-installed SLED 10.I just recoveried it to SLED 10 by the recovery DVD.Does it support SLED 11?

If your machine works with SLED 10 it’ll work with SLED 11. Also some HP Mini 2140s shipped with SLED 11 on them.

However, some HP machines pre-loaded with SLED do ship with additional repos set up by HP that provide packages to support some hardware which SLED 11 SP3 as provided by SUSE doesn’t support out of the box I haven’t been able to determine say whether everything in the HP Mini 2140 is supported by SLED 11 SP3 out of the box. A minute on Google found where someone says everything worked with some Debian variant except for wireless and there’s a link to the required driver. That’s page is dated from 2010 though, so things could have changed since then.