Catalog cache isn't clearing after performing a refreshCatalog


I am facing an issue where the rancher catalog cache is not clearing when I force refreshCatalog

I am using S3 for our custom catalog repo and am running Rancher v2.2.5 in HA configuration in an Air-Gap environment.

Currently, whenever I build my helm charts and stage them to S3, I have to shell into my rancher containers and clear the catalog-cache in order to visibly see my chart updates (after performing refreshCatalog).

Is there any way to disable the catalog-cache?

UPDATE: I should note that I am observing this behavior in our dev environment and for our dev environment, we are staging these helm charts to S3 with the SAME CHART VERSION each time. So I am pretty sure that rancher would pick up the changes made to a chart if it were staged with a new ChartVersion, like they are for our other environments. But for development, we are forced for clear the cache each time so that rancher grabs the latest upload for that given chart version.

Thanks so much,

1 Like

Seems like there have been discussions about this topic, though it seems like it never got solved. Standard refresh works fine if Chart versions are different, but Charts don’t get refreshed if the content of a single version changes. I am on Rancher v2.3.3 .

1 Like

The same issue in v2.5.2.
Steps to reproduce:

  1. crate a helm chart with file
  2. edit file and rebuild the helm chart (don’t change chart version)
  3. Refresh catalog in Rancher - app readme is still the same
  4. update helm chart version and rebuild
  5. Refresh catalog in Rancher - app readme in the new version is changed. It is not changed in the old version