Colour me unimpressed with SLED

So far I’ve had a miserable time with SLED.

Bought new bits for a PC that I wanted to start actually using this weekend (it’s now Sunday night, and the machine is still useless) for some FPGA development, put them together and bought a copy of SLED, because that’s what Xilinx (the company that makes my FPGA) supports along with RedHat.

The initial install goes ok, apart from two things:

  1. The mouse doesn’t work with the KVM switch I have. If the mouse is plugged into the machine, everything is fine. Plug it into the KVM and the mouse behavior is … erratic to say the least. I’ve found several “fixes” for this on the net, none of which work. So far I’ve tried:

    • Changing the protocol to ‘auto’ away from the ps/2 variant. No difference even after a reboot

    • Configuring X to use the evdev driver (as in Novell knowledge base article 7006748). No difference, even after another reboot.

My mouse is still plugged into the machine itself… Not an auspicious start.

  1. The network on the motherboard (an ASUS P8Z68-V) doesn’t work, because SLED tries to use the RTL8169 device driver and its an RTL8111 chip. The 8169 driver is widely known to be broken for a large swathe of 8111 chips, so it’s particularly disappointing that the buggy device driver is still being shipped. To solve this, I found the following on linuxquestions:
    []Downloaded r8168-8.004.00 driver from
    ]$ tar jxvf r8168-8.005.00.tar.bz2 # i unpacked this on the desktop
    []$ sudo mv r8168-8.004.00 /usr/src # move the driver directory from desktop to /usr/src
    ]$ cd /usr/src/r8168-8.004.00
    []$ sudo make clean modules
    ]$ sudo make install
    []$ sudo depmod -a
    ]$ sudo insmod ./src/r8168.ko
    []$ lsmod -a | grep 8186 #just to check it was there
    ]$ cd /etc/modprobe.d
    []$ sudo touch blacklist-network
    ]$ vi blacklist-network # add r1869 to black list

So now I’m almost there. Now I try to update to SP2 (since the download link was to the SP0 when I bought the support) using ‘wagon’ as root - I found that on these forums, it wasn’t obvious from the Desktop how to change the service-pack level… I was rather hoping that the above two things would have been fixed in the service packs… so:

  1. run wagon as root. Let it do its stuff, and an hour and a reboot later, I have … a mess.

    • Now, the ‘main menu’ applet crashes and won’t reload. There’s no easy way to get to anything now. Fortunately I’d dragged a GnomeTerminal icon onto the desktop, because otherwise I’d be SOL. Also, it seems to have only gone to SP1, well, ok perhaps it has to do it in stages…
  2. Also, the network no longer works (well, ok, if it hasn’t been fixed I sort of expected that might happen), so I go to do my above routine, and … it fails. Looks as though the kernel source might have been removed ? Not sure because I had to change the baby’s diaper so I was in a rush, but step #5 now fails with ‘make’ aborting with a ‘file not found’ message (from memory). So hey, I’m SOL anyway. No network, no way to get a network. Great.

  3. So then I decide, what the hell, I’ll download and do a fresh install of SP2 this evening - I’ve got the early shift with the baby so there’s plenty of time to download the DVD, burn it, and start the reinstall, right ? Nope. After registering on Novell’s site, it seems there’s no link to my credentials on Suse’s site (which knows about my “digital rights” to support) so even though the box itself could potentially (if it had a network) download the service pack, I can’t do it from my Mac. There doesn’t appear to be anywhere I can just type in my “digital rights” code, either.

Frankly, this level of run-around is what I expect from a fly-by-night seat-of-the-pants one-guy-who-does-it-all startup, not a company which claims its support is its distinguishing feature. QA is clearly lacking, and QA is essentially what we’re all paying for. So now it seems the only way forward with Suse would be to get a network card that it doesn’t screw the driver up for, and use 2 mice on the desktop, one for the Suse machine, one for the other 3 machines.

As I said at the start, colour me unimpressed.


You indicate that what you initially downloaded was ‘SP0’, by which I assume you are referring to the initial SLED release, officially known as SLED 11 GA. I find myself wondering how many of the problems you describe come from that as SLED 11 GA went end of life in December 2010. (

Your motherboard appears to have been released in 2011 and has an SandyBridge chipset, which SLED 11 GA won’t support. I put SP1 on a machine with SandyBridge chipset and the networking didn’t work without installing some extra packages. (

If you just bought SLED and got given a link to download SLED 11 GA, well that’s unhelpful. If you can post (or PM me) details of how you bought SLED and the link you were given I’ll see if I can get that to the attention of someone relevant.

Can you access the SLED 11 SP2 download page at ?

At some point you might also find it useful to download the SLE SDK 11 SP2

The KVM switch thing puzzles me. I’ve never encountered an issue like the one you describe with either a PS/2 or USB switch.

That’s news to me. If the product has gone end-of-life, then I’d normally expect the replacement to be the default option offered. I don’t remember the exact sequence of how I got the out-of-date product, but I remember it only took a few minutes, so it can’t have been that obscure a path through the website…

There was no direct link in any email sent, I was taken to the download page as part of the fulfillment process after paying for the product. However, there is a link to in the “thank you for buying” email that Suse sent out, and if I follow that, click on ‘I need help downloading’, type in my order-number/password, I get a link to download SLED-11-DV-x86_64-GM-DVD.iso again.

I had found that link on the forums before I posted this thread, and on clicking ‘proceed to download’, and typing in my username/password, I was given the message that no content could be found that matched my username, or words somewhat to that effect - it was late… That’s what I meant in step-5 in my first post. I probably ought to have spelt it out more.

So, I tried it again. I can get to the link you post, I click on ‘proceed to download’, I do so, and type in my username/password, and I get a blank page with the URL “”. I ought to mention (I forgot, in the first email) that when I registered with Novell in step-5 above, I got a page full of HTTP errors (frameset-like or iframe-like) telling me I’d tried to redirect from an HTTPS to an HTTP page after I’d typed everything into the registration page. Again, not tremendously impressive, but it did all seem to work so I figured it was just the “thank you for registering” page… I don’t know if it matters, but I’m using Safari to do this.

Indeed, it was a puzzle to me as well, though Novell are clearly aware of it. The above-mentioned Novell knowledge base answer is entitled “SLES11SP1 showing erratic mouse behavior with KVM / BCM solutions”. The symptoms are that X mouse movement is fine, Y movement is as if the acceleration is set to about 1000%, and it also creates random “clicks” of the mouse as it is moving. This makes it … difficult … to use. Changing the driver in the admin utility in Yast (which takes forever because of the erratic behaviour) doesn’t help.

[addendum: Oh, and I just got the ‘blank-page’ thing again when I clicked on ‘Go advanced’ to preview this. It took me to the login page where I typed in my username/password, then was taken to a blank page. The only reason this post is still here is due to the auto-save feature of the forum software, which is pretty cool]

[addendum: Since the forum started working again, I thought I’d try the download URL you gave again, and this time I wasn’t asked for a username/password and was taken straight to the actual download links after clicking on ‘proceed to download’. Looks like it’s just that the password authentication system is screwed up on the website. At least now I can download the S2 iso]


I’ve long since deleted all my copies of the SLED 11 iso, but that does look like the filename it would have (assuming DV- is typo for DVD-).
I’ll raise this and hopefully someone will sort that out.

[QUOTE=sjg69;3832] Looks like it’s just that the password authentication system is screwed up on the website.
Unfortunately there have been some problems with the availability of both the forums and of late and I’ve seen some issues with authentication. I believe relevant people are aware of these issues.

I hope you have a better experience with SP2.

In fairness, I should report that I did. It automatically found the ethernet device, and I dealt with the KVM issue by returning the KVM switch… I’ll look online for one that people report as working, and try that instead.

So, all is sweetness and light in the land of SP2…

Simon :slight_smile: