Get rstatd to bind to a specific port

We are running SLESz 11.2. I want to use rstatd for server monitoring. Rstatd runs under inetd, and if I cat the /etc/xinet.d/rstatd file, I get the following:

service rstatd { type = RPC rpc_version = 2 flags = IPv4 socket_type = dgram protocol = udp wait = yes user = root group = root server = /usr/sbin/rpc.rstatd disable = yes }

There is no port specification in this file, and I believe that even if you specify a port entry, the xinetd will ignore it.

One can therefore only configure the firewall everytime that the port changes, run without firewall or not use rstatd at all.

Are there any solutions for this ?



It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team

It works for us.

  1. create /etc/xinetd.d/rstatd-server with contents
    service rstatd
    disable = no
    type = RPC
    socket_type = dgram
    protocol = udp
    server = /usr/sbin/rpc.rstatd
    wait = yes
    flags = IPv4
    port = 60222
    user = root
    group = root
    rpc_version = 1-4
    instances = 1