Help! Docker ARM64 images not loadable into k3s on raspbian buster 64 bit?

Dear ladies and gentlemen,
playin’ around with my raspi4 and k3s… I really LOVE it, thx to the great work you did giving birth to a líghtweight k3s! Just one thing there is I cannot resolve but I would dearly like to know:

MongoDB offers only ARM64 images on DockerHub. Even though I tried everything to make my Raspbian 64bit (
1 config.txt changes to arm_64
2 cat /proc/cpuinfo confirms success (CPU architecture: 8, BCM2835)
3 /etc/os-release confirms “buster” (which does not say much)
4 sudo k3s check-config gives a clear overall OK (including legacy ip tables and cgroups)

… when I sudo k3s kubectl describe pod I STILL get

  • … Failed to pull image “mongo”: rpc error: code = NotFound desc = failed to pull and unpack image “”: failed to unpack image on snapshotter overlayfs: no match for platform in manifest …

for mongo or mongo:latest (which is labeled arm64)

Did I do something wrong? Is it Raspbian that nails me down to 32bit even though the kernel operates in 64bit?

Any help highly appreciated!
Thx very much
PS: Of course I can install a seperate mongodb cluster with sudo apt install, but this delivers mongodb 2.4.14 which is really old now (now we have 4.2.5)

PPS: In case you find the time pls. pls . pls. get Longhorn run on Raspi4 :slight_smile:

I’m having a similar issue with my Raspberry Pi 4 + K3s. This issue has been noted here: Github Issue