How to Force Change Pod IP

I’d like to force change the Pod IP of a System workload in a custom cluster. Editing the YAML yields no change, as it instantly resets after edit.

How do I force a specific Pod IP address?

So I would recommend looking at using a service IP.
Because a static IP cannot be assigned to a Pod because of the dynamic nature of kubernetes’ IP layer.

Also, there is an open issue for this feature.

1 Like

Thanks for the information. However, my problem is not really about static IPs, but rather about the wrong IP being selected in the first place.


So by force changing IPs I would at least want to see if the only issue remaining in the Cluster is the wrong IP. Since I could meanwhile work on a different issue, while the IP issue is not resolved, yet.

No matter what settings I change, no matter how I set up my node, e.g. calico always picks the IP address from the wrong interface (at least the only way that it could find out about the IP address is through an interface, or actually, it finds it out from the Node IP which is split into 2 different IP addresses, one being the selected and correct one, the other one being the one I want Rancher to ignore entirely, as seen in the above comment from the other thread.).