how to install midnight commander...or anything else

Hello you,

thank you for advice and pointing to advice.

Since 3 days I have the opportunity to discover the huge world of linux. I bought an HP 655 laptop with SLED 11 SP 2 preinstalled.
For my problem I was not able to find a solution in: “Suse Gnome User Guide” and “OpenSUSE 11.0 and SUSE Linux Enterprise Server Bible”

  1. I want to install a “third party?” program “midnight commander” that I downloaded from sourge forge. It has no self-installing routine (of course). And it is no rpm-package (or I can not discover it). The methods for installing described in the above mentioned books do not help, cause I cannot “bring” the tar-file into yast.
    In the tar-file there is a text file “install” and I managed to start a ./configure process, but that lead only to a lot of error messages.

Please share your knowledge with me how to install programs, that are not “originally” installed and which are no rpm-package. Or guide me to a useful beginner guide.

  1. I need to read a lot. But I found the adobe product very slow. So I found in yast “evince”. But I cannot “bring” it to the “preferential application” window (the window that opens when I click on “computer” in the left/down corner).
    I found (yes indeed a rather bizarre) way to start it: launch “gnome terminal” and than enter “evince” in the command line. How can I start that program easier…

  2. Which epub-reader are available, which would you recommend and how to install the reader.

not so important questions – for ppl with some time and compasion:

  1. I use a Pocketbook 622 and I wanted to copy books from the laptop to the ebook-reader. I tried it with two usb-ports. Nothing. Than the support from Pocketbook answered (very fast) that I should try all usb-slots. And the third port (on the left laptop side) worked.
    How is that possible. Why do the other slots not work. I changed/installed nothing.

  2. With windows I used firefox. When I clicked in the address field, the former adress was marked and it by simple typing the new address, the former address was deleted. Linux firefox has not this behavior. If I click there, the former address is not marked.
    Can I change this behavior?

Thank you for advice
an emotional good day wishes

Midnight Commander is included in SLED. You should be able to simply install it from the repos. As root:

$ zypper in mc

or search for it in YaST > Software > Software Management
If you want to build applications from source you’ll need a lot of -devel packages which you can find in the SUSE Linux Enterprise 11 Software Development Kiy (you only need the Media1 download)

If you click on Computer then you’ll see a button marked ‘More Applications…’ Click that and it will open the Application Browser. Find evince there, then right click on it and select ‘Add to Favourites’

Can’t help you with that, I have no experience of epub readers.

It could be that the Pocketbook 622 requires more than the 500ma which a standard USB port can supply and there is one port on your machine that supplies more than 500ma to devices which request it. That’s just a guess though.

Try double clicking.

Hi Mike,

thanks for your explanations. MC is now installed (Yast).

I installed evince and evince-lang with Yast. Although the software manager indicates, that evince and evince-lang are installed, it is not displayed in the application browser…
What must I do to fix that.

tx for help

Sorry, I forgot, Evince does not show in the Application Browser. Years ago, someone decided that Evince should not show up in menus. If you are interested in why read
Some people (for ="]example) think it’s the wrong decision, myself included.

I have modified Evince on my own machine so that it does show up in Application Browser. Run this command as root

$ sed -i '/NoDisplay/d' /usr/share/applications/evince.desktop

You may need to re-run that in the future after any updates to the evince package are installed. If Evince still does not show up in the Application Browser run this command

$ killall application-browser


You need to actually upload the files :wink:

Hola Mike,
I stepped in until comment 10. Interesting how “politics” are developing in all social (even technical ones) contexts…

For a longtime windowian it would be fine to “see” all available (installed and not installed) programs (with good grouping better of course – “software manager” is not that helpful cause so much programs and “special” naming…), so I can test, browse and discover easily without even knowing beforehand that such wonderful programs exist…(and my guess is, that there are more wonderful and serving programs in linux, than I ever imagined - but will I see/find them???).

But I learned now, that evince I can launch through right click on the file. Thanks for your energy, but I think than I do not need to have it in the start window (or do you recommend it?).

You need to actually upload the files.
Guess what. I reckoned with your transcendental clear-sightedness.

Interesting is, that my daughter (8y) in the ultimate time claims, that she has some kind of clairvoyant abilities.
I am very skeptical, but if she proves it…


ps: for epub-files I found “calibre”. On the website I could copy a command line argument, pasted it in a bash and the program was installed (windows manner, but for a beginner to do a manual installation procedure is not manageable.


short complement:

if you search “akrobat” or “acrobat” you do not find anything in the software-manager. But know in the world is the reader as acrobat…
The name there is “acrored”…