I need help with importing my cluster

So… I kinda screwed up my rancher cluster I think…
(This cluster is running on 1 server at my home, with the rancher controller running on another server on the same network)

My controller crashed irrecoverably (Running in a FreeNas VM) so i chose to spin up another one, but instead of importing the old cluster i ran the create cluster command again.
Obviously this didnt work since the cluster wasnt clean, I then found the import command, this is where things get tedious.

Trying to import the cluster with

curl --insecure -sfL https://domain.tld/v3/import/nqfl2klqq4xlwrpqqhjtjvx5khp7khtrfhc2vlg9xhnf6j2b7xxffjc.yaml | kubectl apply -f -

yields

x509: certificate signed by unknown authority (possibly because of "crypto/rsa: verification error" while trying to verify candidate authority certificate "cattle-ca")

I have tried adding the cluster-binding but i get the same error.

and at this point im not sure where to go next.

The node is a CentOS host
Rancher version 2.2.2

Any help or pointers at all would be very helpful