Migrating from 1.6.x to 2.x cannot create a link to db pod


#1

So I am trying to migrate from Rancher 1.6.21 to the newest stable release (2.1.5) of rancher 2.x. I ran the migration tools on my stack from 1.6 and got all the deployment, service, claim files did some minor changes to them as outlined in the migration blogs, did some other changes from the UI Edit pane like opening the hostPort and setting the imagePullSecrets. Anyway right now I have deployed my database POD one node, I am having my API project in another pod on another node, what I want it to be able to connect these two pods. In rancher 1.6.x that was pretty simple I could just add a Service Link when creating my service which was pointing to another service in the same stack or another stack give it a name like database and then use that name throughout my service. Now I cannot figure out how to achieve the same thing in rancher 2.x even trying to follow the guideline I seem not to understand those guideline because tried it now for 2 days without any luck to connect my services (PODs). There are some rancher migration videos on youtube, where they just deploy a mongo service point to the db server, which I also tried (using mssql) but they don’t outline how to make the web POD see that service (in my case my api POD), or is there something I have missed there?