Offline Upgrade for RancherOS


#1

I tried to upgrade an offline installation from RancherOS v1.4.2 to RancherOS v1.5.0 because there is no internetconnection available.

  • I pulled all rancher/os images, copied to usb-drive and loaded to the offline installation
  • I updated cloud-config.yml with:
    #cloud-config
    rancher:
    upgrade:
    url: /etc/releases.yml
    image: rancher/os
  • I created /etc/releases.yml with:
    available:
    • rancher/os:v1.5.0
  • sudo ros os list returns:
    rancher/os:v1.5.0 remote available
    v1.4.2 running
  • sudo ros os upgrade -i rancher/os:v1.5.0 fails while pulling os-upgrade (rancher/os:v1.5.0)…

Anyone solved this problem?


#2

I use virtualbox offline environment and can success upgrade to 1.5.0. You can try my steps.

sudo system-docker load -i os1.5.0.tar

sudo ros os upgrade -i rancher/os:v1.5.0

#3

This will not work without Internet Connection. See my last line with the error:
sudo ros os upgrade -i rancher/os:v1.5.0 fails while pulling os-upgrade (rancher/os:v1.5.0)…


#4

My steps is worked with no Internet Connection. You only need to pre-download and loaded the corresponding version of the image such as rancher/os:v1.5.0 then run ros os upgrade -i rancher/os:v1.5.0. The reason for your error is that the corresponding image cannot be found. Are you sure that you have already loaded into the system-docker?


#5

I was able to manage an offline upgrade. The important Point was to create a more detailled releases.yml with:
available:

  • rancher/os:v1.4.2
  • rancher/os:v1.5.0

It is important to have both entries, one for the current (1.4.2) and one for the offline package (1.5.0)

Problem solved. Thank you