v0.4.3 to v0.4.4 Upgrade issue

Hi all,

I’m attempting to upgrade RancherOS to v0.4.4 (from v0.4.3) on a VirtualBox VM and am receiving this error after the image is downloaded:

FATA[0005] API error (404): No such container: once_os-upgrade_1

Based on prior posts, I’ve tried a reboot but this hasn’t made a difference.

Probably worth noting that I’m using network interface bonding (just in case).

Any ideas?


This can be fixed by removing any containers associated with upgrading (names that contain “os-upgrade”).

Had you previously tried to upgrade? There are some known issues in the previous releases that we have now fixed in v0.4.4. Going forward, they shouldn’t be an issue.

Or if it’s your first time running sudo ros os upgrade then you shouldn’t hit this issue.

Thanks for the suggestions both.

I think I was being a bit premature. I was trying this about 12hrs after 0.4.4 was released and the command still considered 0.4.3 the latest version. I could pull the 0.4.4 image and was trying to force it’s installation. Have just tried again and it’s all good.

Interestingly, the ros -v command still reports v0.4.3;

[rancher@ranchersvr ~]$ sudo ros os list
 rancher/os:v0.4.0 remote
rancher/os:v0.4.1 remote
rancher/os:v0.4.2 remote
rancher/os:v0.4.3 remote
rancher/os:v0.4.4 local
[rancher@ranchersvr ~]$ ros -v
ros version v0.4.3

Which console are you in?

Can you do a Suso system-docker ps?

It seems it took a few more reboots to sort itself out - looking normal now:

$ sudo ros -v
ros version v0.4.4

$ sudo system-docker ps
CONTAINER ID        IMAGE                       COMMAND                  CREATED             STATUS              PORTS               NAMES
d1e7b787b5e7        rancher/os-console:v0.4.4   "/usr/sbin/entry.sh /"   About an hour ago   Up About an hour                        console
ed654d2bfa04        rancher/os-docker:v0.4.4    "/usr/sbin/entry.sh /"   3 hours ago         Up About an hour                        docker
76e3d6dec7aa        rancher/os-network:v0.4.4   "/usr/sbin/entry.sh /"   3 hours ago         Up About an hour                        network
032d732d6796        rancher/os-ntp:v0.4.4       "/usr/sbin/entry.sh /"   3 hours ago         Up About an hour                        ntp
7817d19cdcd8        rancher/os-acpid:v0.4.4     "/usr/sbin/entry.sh /"   3 hours ago         Up About an hour                        acpid
197059d0feae        rancher/os-udev:v0.4.4      "/usr/sbin/entry.sh /"   3 hours ago         Up About an hour                        udev
8393346e760a        rancher/os-syslog:v0.4.4    "/usr/sbin/entry.sh /"   3 hours ago         Up About an hour                        syslog

Happy to start fresh off v0.4.3 to test again if you’d like?


When v0.4.4 was released, it was not initially pointed to v0.4.4 for upgrades until about 24 hours after, so now it should work as expected.

Thanks Denise, that certainly reflects my experience.

Thought I’d do this again and I’m seeing the issue, this is after two reboots:

Update: It seems to take around an hour or so before it sorts itself out. No big issue but somewhat confusing I’d imagine.

sudo system-docker images
REPOSITORY               TAG                 IMAGE ID            CREATED             SIZE
rancher/os               v0.4.4              593f2d72f0c3        6 days ago          194.3 MB
rancher/os-preload       v0.4.3              983c005fe53f        9 weeks ago         25.65 MB
rancher/os-console       v0.4.3              d9b2845438df        9 weeks ago         25.66 MB
rancher/os-udev          v0.4.3              8dc9eee7501f        11 weeks ago        25.65 MB
rancher/os-syslog        v0.4.3              987960440665        11 weeks ago        25.65 MB
rancher/os-statescript   v0.4.3              24355446800e        11 weeks ago        25.65 MB
rancher/os-state         v0.4.3              0fe21afc3049        11 weeks ago        25.65 MB
rancher/os-ntp           v0.4.3              3e2d57d4ae21        11 weeks ago        25.65 MB
rancher/os-network       v0.4.3              5288f2eb944e        11 weeks ago        25.65 MB
rancher/os-docker        v0.4.3              6a4e2f959df2        11 weeks ago        25.65 MB
rancher/os-cloudinit     v0.4.3              5c47e775e016        11 weeks ago        25.65 MB
rancher/os-autoformat    v0.4.3              00182a66713c        11 weeks ago        25.65 MB
rancher/os-acpid         v0.4.3              0fa901101944        11 weeks ago        25.65 MB