Problems with binding a service to a public host address

Hi there,
I’m using rancher now for some time and I just ran into a problem while setting up a brand new host.
I’m trying to bind a specific IP to a public host address. To achieve this I did set up a keepalived service and so far the IP is pingable. But when I’m trying to start my service I get this error:

Failed to allocate instance [container:1i851]: Bad instance [container:1i851] in state [error]: Allocation failed: No healthy hosts meet the resource constraints: [ portReservation, instanceReservation: 1].

What I tried so far:
-Using different IP’s
-Using a loadbalancer instead -> same error
-Using another keepalived service -> same error
-Set the port only-> Service is reachable on ranchers host ip adress and the host adress i picked for the service
-Started a container manually on rancher os with "docker run -p ipadress:802:80) -> works fine
-Tested different loadbalancer versions

System informations:
-RancherOS v1.1.3
-Rancher v1.16.4
-Keepalived: alterway/keepalived or osixia/keepalived image

Am I missing something here because I’m pretty sure this worked in the past. Any suggestion would be helpful.


I have hit the same issue when i tried to bind a port to or to host primary IP:

  • Using CentOS 7 (3.10.0-693.17.1.el7.x86_64)
  • Docker 17.12.0-ce, build c97c6d6r
  • Rancher 1.6.14

Kind regards,