Project Harbor (container registry) as a Rancher catalog item

Hi guys.

I am in the process of opening a PR to include Project Harbor (an Enterprise Container Registry) into the Rancher community catalog. Before I do so, if there is anyone willing to give it a try, I’d be happy to hear if you found it useful (but most importantly if it worked :slight_smile: ).

The repo is here: https://github.com/mreferre/rancher-catalog-extension

If you want to know/hear more about the “mechanics” of how the setup works you can read this blog post: http://www.it20.info/2017/01/vmware-harbor-as-a-rancher-catalog-entry/ (note I have just recently updated everything to work with Harbor 1.1.1 which is the latest release).

Thanks.

1 Like

BTW the item for now only works with the Cattle environment. I may be adding K8s (and Dcoker?) in the future depending on how it goes.

Hello !
It’s a good job ! Exactly what I was looking for !

Nevertheless, I’ve tried Harbor in my brand new Rancher, hosted on a Linode server but it fails and I don’t understand why… :thinking:
I’ve tried to setup Harbor from the “Add from Catalog” button, directly from my Rancher Catalog.

I only have one host in my Rancher (the Linode server that only contains the Rancher stack).
I’ve selected the “1.1.1-rev0-singlehost” template of VmWare/Harbor.
And then, I’ve just configured the “IP/Hostname/FQDN” field with the public IP of my unique host.

I’ve got those errors (I’ve tried many times, with different template, IP etc.) :

I don’t think that the ports :80 and :443 are already in use. The Rancher-UI is on the port :8080, and none of the “publicEndpoints” of my host concerns the port :80 / :443 etc. (I’ve checked from the host API JSON).

In my Rancher/Infrastructure/Storage I have no storage drivers. Is it normal ?

Where can I found a solution ? Have you an idea ?

Thanks !

Hi Damien. Sorry for the delay. Can you please try the latest version (https://github.com/mreferre/rancher-catalog-extension/tree/master/templates/project-harbor/4) and follow exactly the prerequisites in the page linked above?

From the error message you are getting it looks like there is a mismatch between the tags the host has and the tags the catalog item expect to see to be able to schedule the containers.