Rancher 2 quick start - unable to create ingres


I am a newbie. I ran through the quickstart guide.

I provisioned a new virtualbox VM running ubuntu 19.04.

I installed docker 18.09.7 on the VM (with apt-get not snap) and installed Rancher as per the Quick Start Guide “Deploying Rancher Server”. I am using “localhost” as the server url.

I next attempted to follow the instructions in the “Workload with Ingress QuickStart”.

The Hello container started up, but the Ingress will not start.

docker logs on what appears to be the ingress vm (Calico) show this error message…

Kernel RPF check is set to ‘loose’.


I destroyed the VM, and created two new VMs one for Rancher and one for the worker. I was able to get Rancher to say that the Ingress is active. However, I cannot see how to get the link to my hello-world app as per the quick-start guide.

It shows is “xip.io > hello-app” but the hyperlinks are to internal pages in the Rancher app, not to the hello-world app.

my Ingress is named “hello”. My namespace is “default”. My app is “hello-app”. My IP address is So based on the docs I should have a URL…


This just give me a message “default backend - 404”

What should the link be and where is it in the software?



I deleted my VM, and created two, one for Rancher and one for the worker. After that, the ingress listed as active.
However, the URL for the xio.io link never displayed.

I tried numerous guesses, such as http://hello.default., but they all show
“default backend - 404”.

Is the application running?

My project is default, my ingress hello, my ip address is My app is hello-app. I left the path blank in the url in the ingres config. I set port to 80.

sudo sysctl -w net.ipv4.conf.all.rp_filter=1

running this command in the hosting OS helped me with the same issue… see https://www.theurbanpenguin.com/rp_filter-and-lpic-3-linux-security for details