Rancher cli deploys previous chart version after deleting it

I’m using rancher cli v2.4.3 and using it to deploy charts to an rke cluster.
I’ve deployed chartmuseum as a Helm catalog and a Docker registry in the rke cluster.
I’m able to deploy a chart that has been uploaded to the catalog.
Now when I run the following workflow:

  • Delete the deployed app (i.e. rancher apps delete)
  • Delete the chart from the catalog
  • Make some modifications to the Helm chart without changing the Chart version
  • Upload the chart to the repo
  • Deploy the app (i.e. rancher apps install)

The result is I get the previous deployed version without the changes, for instance, let’s say I have changed the app name in the values.yaml which ultimately substitutes the name for the Deployment name, from app1 to app2, even if I had deleted the app, I keep getting app1 instead of app2.
Initially I though it may be related to chartmuseum, but I did the same test using plain Helm commands (i.e. Helm install) and it worked son now my guess is that some data is still stored under rancher thus deploying the old version everytime.