RancherOS: Bare Metal Install Failing

Rancher Labs:

 Containerization of apps is evermore elegant and flexible an architecture when services normally thought of as system are also loosely coupled.  This extends all the way up to the kernel.  For example, ssh->git_system->git_repo_data volume allows changing the security policy and/or repos with ease.  A bit like the Chain of Responsibility design pattern for software.  With this is mind, RancherOS makes the most sense as a container OS.  Thank you.

 Having said that, I've trouble with a bare metal install.

The most recent .iso that even gets to a login prompt on boot was that posted Apr. 11th.
Setting networking with the default rancher:rancher account; no problem.
Creating a cloud-config.yml config seems straight forward.
The install itself, seems to go without a problem using the following command.
rancheros-install -f -d /dev/sda -c cloud-config.yml

However, things fail from there. cloud-init fails on boot. A login prompt appears though, so it seems all will be OK with a little manual networking again. Nope! Can’t login with the account used to generate the keys and setup in cloud-config.yml. The metal is now just a brick.

Might there be a single encapsulated AND tested step-by-step document with an example account?


RancherOS currently doesn’t support Users in Cloud Config. But we do support adding in SSH keys and you should be able to ssh in.

There is an example of how to install to hard disk, which uses rancheros-install.

Could you share your cloud config file?


Thanks for the quick reply.

Noticing inability to cleanly or boot at all with the Apr 11 .iso after failed installs (even after deleting the partition table), I resorted to wiping the drive with dd and start anew. This suggested the latest .iso might work after a dd. It did!
This also allowed ruling that bit out as possibly influencing the issue with SSH; although, there doesn’t appear any reason it would have.

All went well, even SSH! No further issues to report at this time. An encapsulated document of the ENTIRE process (perhaps recommending a dd) might help though, rather than references to others with bits that don’t apply and potentially confuse.

Thanks again!


After reading through the 2 posts with regard to failing rancherOS install on bare metal, I am still having issues. I have tried all variations of cloud_config from just the ssh key, to adding networking, etc. still won’t boot with what seems to be a network interfaces error.

I am using VMWare Fusion to create the VM for rancheros , is this not possible? Is the rancherOS specific to and Ubuntu VM install?

HELP !!! and Thanks in advance.


I hope I understand correctly what you’re doing.

I’ve not tested a bare metal install via VM well enough to comment other than I recall it worked, but didn’t load kernel modules for a console and ended up without networking; uselessly very headless.

Rather than via VM, try booting from the *.iso. It may also help to wipe the the entire drive with a dd command first. From the *.iso in-memory system, configure networking with ip commands: ip link, ip addr, ip route, and also set /etc/resolv.conf to preferred DNS server. This should allow the installation process to pull system images over the Internet.

Let me know how far that gets you; should be all the way assuming your config. file is good.


Thanks for your reply, you I would think (I unless i don’t understand) boot the RancherOS in virtualbox or vmware and it should act as bare metal. I could be wrong but i would think it should act as any other install of OS to a VM. The install goes fine, it is on boot that it hangs like it can’t figure out the docker rancherOS networking.

@Bill_George and @matthew We are working on v0.4.0 of RancherOS which will be released within the next 2 weeks. At that time, bare metal installations should be much easier and we’ll be providing more information of where the boot is failing.

We’ve seen the boot fail due to some kind of network configuration, but the logs aren’t providing us enough detail. As soon as we release v0.4.0, I’ll let you know.

1 Like

Thank you Denise, will look forward to this new release.