Service Pack Migration with multiple installed products

Hi all,

I’ve some machines which got some special suse channels like HA or SDK. Suse Manager 3 will, after applying a highstate, install the proper packages and show it under Installed Products in System Info of a Client.
After that it seems that its not possible anymore to do a SP Migration from the Suse Manager GUI. Only the manual way worked then (providing the next SP channels and do a “zypper dup”).

Alternatively I had to remove the channels and apply a highstate on the machine. After that I was able to do a SP Migration.

Does anyone had the same issue?

Greets Matze

What does “its not possible” mean exactly ? Not offered or failing ?

The SP migration offered in the GUI goes up the chain of cloned channels to find the original vendor channel from SUSE. This is the only way to ensure the correctness of the attempted SP migration. If this chain is broken, the SUSE Manager GUI refuses to offer the migration.

You can now either

  • create new clones, starting from the SUSE vendor channel
  • continue to use ‘zypper dup’
  • use the XMLRPC API. The API does no checking whatsoever. Choosing the wrong channels will break your client system. With great power comes great responsibility.

The GUI shows “There is currently no migration available for this system. Either the latest Service Pack is already installed or possible target products are not available. Please use the Setup Wizard to identify and add missing products.”
Seems strange as anything else is working like it should. Package-Installations, Updates and so on.

As I’m not very familar with the API I’ll continue with zypper dup. I was just interested, if someone else faced the same problem? But it seems not…

Thanks kwk!

I ran against the same wall and SP-Migration from GUI leads to the same Message “there is currently …”. After lot debugging with SuSE Support we figured out, that the problem was the certification-module, which has changed from SP1 to SP2 and also from SP2 to SP3 (SLE12). After disabling the modules and uninstall the product releases the SP Migration from Web-ui worked fine.

Thats just for Info - perhaps other users were trapped here.