SLED 12 SP3 Installation problems

Problems with SLED 12 SP3 install.

Coming from LEAP 42.3.

Install and upgrade installs tried across two different systems. Following are the problems:

  1. Can’t seem to find the system files on upgrade second time around.
  2. Doesn’t reformat the swap from what LEAP 42.3 does
  3. Decides to name the system – doesn’t ask, doesn’t give a obvious place to fix it first.
  4. Gets 75% of the way through the system file search and loops doing ???
  5. Python-six RPM doen’st get installed – Boot is screwed as a result
  6. IF one gets the system to boot, then Gnome never displays a prompt for login
    8)OPENSUSE doesn’t do LIVE DVDs anymore.

So, to fix this and get it all working, I had to resort to a KNOPPIX live DVD and forceably format the / partition, all swap partitions before SLED 12 SP3 would correctly install.

This is a bit sad because this is the second time I’ve attempted a SLED install. The first time was over a year ago and I paid for that and had one day to install and go. This time I had to get things working because of Taxes and having to get either Vbox or VMware player working.

A 60 day trial is assumed to just be drop in the tray and boot, install|upgrade and go. I usually get paid to do QA work.

Again, KNOPPIX to the rescue to get it all to work. And Sales says you only get the forums, no real support from SUSE.

Hi and welcome to the Forum :slight_smile:
There is no upgrade path from openSUSE to SLE, always choose a fresh install. Normally if there is an existing system, it pays to use the expert partitioner option in YaST, rescan the drive(s) and setup the partitions via edit and set to format… In the Network setup (from memory at the registration screen) you can select the network button at the top and set the hostname here.

I always use a Live openSUSE Tumbleweed live (openSUSE Leap 15 version is on the way) setup for maintenance stuff or just boot to rescue mode if don’t need a GUI…

What are the system graphics?

I’m a bit baffled, because I’m not a newbie here. Don’t know why this system thinks I am a newbie.

In my world, when an entity gets a system for trialing and they report problems, they report them to the L3 and developer personnel. But then I’ve retired from the IBM Mainframe world as a developer. However, in my day job I take care of in-house developed tools. So I have a lot of customers since I work for a very large company (not IBM).

In other words, I am use to professional support and give the same.

First, I’m using SLED not LEAP. I’m done dealing with the mangled installs that take forever to get fixed. So I expect an install that I have to pay for has been correctly tested. :mad:

The problems I had with the LEAP 42.3 install drove me to deciding to go the SLED route and pay for the product and theoretically get professional support. Apparently support for SUSE when someone is doing a trial is to have them use the community to do the support. When do they find out that their install system has some design issues?

Again, my second time to attempt SLED as an installable system. Only with this attempt, I had to make time to fix it… So I did and have it working. I was reporting what I found.

Next, SLED 12 SP3 contradicts this statement “There is no upgrade path from openSUSE to SLE”. It recognized LEAP 42.3 and said that it was update-able. Is this yet another error in the installer? :rolleyes:

Then there is the mangled Python-six rpm. I had it happen on both systems where I attempted the install. It happens with the upgrade.

Your memory of how to fix the Network name of the system is confused with LEAP. SLED does not ask, and I could not find where to get to that to prevent what I knew was about to happen. So upon first boot I went in and fixed it immediately. :slight_smile:

It make no difference what the graphics were, both systems had the same failure. One is using NVidia and the other is using a Radeon adapter card.


Even though it recognizes Leap as an installed system, it still needs to be a fresh install… The synergy for SLE 15 and Leap 15 will be closer, but again it’s still not a supported upgrade path…

If you upgrade it will leave openSUSE remnants (@System packages) which may very well be the case with python-six since they of the same release (different build);

Repository     : openSUSE-Leap-42.3-Oss
Name           : python-six
Version        : 1.9.0-8.4

Repository     : SLED12-SP3-Pool for x86_64
Name           : python-six
Version        : 1.9.0-9.7.1

During the install did it add the proprietary driver for the Nvidia card or just the nouveau one? Is this a modern radeon card (eg GCN) but Gnome DE should work fine on radeon?

It may pop up the Network option if the ethernet cable is not connected, else it can be fixed at the summary page. It’s a definite option on the upcoming SLE 15 in beta testing.

Hi Wylbur

Your account shows as only having been created today, hence from that perspective you are ‘new’ If you’ve used some other account on This system, then logging in with it may imply some grey hairs earned.

Your ‘world’ sounds like one of those where since instances are a few factors pricier than a single PC operating system, hence a Very different ecosystem for support. Professional support is available here Once you’ve paid for it. The whole Open Source based ecosystem is based on self service and community support first, with a many vendors such as SUSE making available full direct support available for a fee. When the product cost is more in line with a tire than a whole car, there just isn’t any incentive to spend a whole lot of effort hand holding each and every Possible sale. The large number of the inhabitants of these forums are not used to the world you come from, this world has a different culture. To help acclimatize to this world, I would suggest perusing The Jargon File (aka The New Hackers Dictionary)

With any PC operating system, there will be an attempt to utilize what has been left before(even if not officially supported), but it always has been a case of your mileage will vary. It’s always been an optimal path to start with a flushed/clear disk.

The reason for asking about the video card is because your symptoms triggered thoughts on issues where it very much matters which card(s) where involved. When you are asking for help, you get a whole lot further when you check your ego about what is and isn’t relevant and just answer the expert’s questions.

Andy, Adventuring in the Chaos that is our various ‘worlds’