SLED11SP2 Only works with x11failsafe

Hi there,

i just installed SLED 11 SP2. The setup works just fine. On the first reboot the pc hangs up on switching to the x11 mode.

I tried the x11failsafe option which does works.
I tried an boot with “init 1” and starting sax2 to adjust the issue, but it hangs when switching to graphic mode.
I tried an reinstall off the ati driver, which does not work.

ATI Technologies Inc
Modell: ATI RADEON HD 4350

on the same machine i had an openSUSE 12.1 which does work also.

Kind regards


Have you installed the ati driver from the ATI repository?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 10:04, 3 users, load average: 0.05, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


yes, the were installed during the configuration setps after installation from something like ATI-11SP2 repository

You say the ATI driver was installed during installation but in your first post you said

Which sounds like maybe you un-installed it and then failed to re-install it. So is the ATI driver actually installed?

$ zypper lr -u
$ zypper packages | grep -i ati
$ grep -ir driver /etc/X11/xorg*

Never actually dealt with the ATI drivers myself.


to maybe clearify

it was installed during setup but it failed on startup-
i did a zypper install -f of it and rebooted but it still fails