Sleep states in SLED11


I am attempting to enter each of the sleep states in SLED 11 and am finding that it does not appear to use them. The only two I’ve been able to verify are S0 (awake) and S5 (soft power off).

When I attempt to enter S3 (standby) manually via the shutdown menu my SLED11 machine wakes immediately. When I set it to go to “sleep” after a timeout (the lowest I can set it is 6 minutes) it does go to sleep but the firmware reports that it is still in S0.

When I attempt to enter S4 (hibernate) the screen goes to a SUSE loading screen for a split second, shows some text that goes by too fast to read (looks like the services startup from boot) and returns to the desktop. In the past I’ve been able to initiate hibernate in OpenSUSE but even then it only saved the OS state to the hard disk and went into S5.

My questions are:

Does SLED11 support firmware sleep states?

How do I get it to actually go to sleep / hibernate?

Sleep/hibernate is not something I’ve ever tried with SLED (I actually disable it on SLED machines I manage for reasons I won’t bore you with) but I’ve always found it works fine on openSUSE. It’s the sort of thing that can be very dependent on hardware though.

SLED 11 SP2 has just been released, so my advice would be update to that. Sometimes issues are resolved simply by using a newer version :wink:

Unfortunately using anything other than SLED11 SP1 would cause the AMT drivers to no longer be supported, so that’s not an option. I tried on a different computer and hibernate worked there, but sleep / standby is still not functioning.

When I initiate standby on both systems they immediately “wake” without turning off the monitor.

Is there a setting or driver needed for standby to function correctly in SLED11?