smbclient does not show files correctly (SLES11 SP3)

I’m having trouble with smbclient in tarmode way, I am using SLES11 SP3 x64 (samba-client and samba-3.6.3 3.6.3-0.39.1-0.39.1)
when I run the command

/usr/bin/smbclient \\\\\\\\pcCliente\\\\INSTDSKS -U  -E  -c tarmode\\ full -Tc INSTDSKS.tar 2> INSTDSKS.tar.log

to access windows98 this indicates the error

tarmode is now full, system, hidden, noreset, verbose directory \\win98\\ 195584 ( 4152.2 kb/s) \\win98\\BASE4.CAB ... 1802240 ( 4112.1 kb/s) \\win98\\WIN98_65.CAB 1802240 ( 4121.8 kb/s) \\win98\\WIN98_66.CAB 1802240 ( 4680.9 kb/s) \\win98\\WIN98_67.CAB NT_STATUS_NO_SUCH_FILE opening remote file \\win98\\IN98_68.CAB (\\win98\\) directory \\Century\\ directory \\Century\\\\ directory \\Century\\\\\\ directory \\Century\\\\\\\\ directory \\Century\\\\\\\\\\

same error but with debuger -d 10
  [CODE]     cli_pull_read_done: Pushing 0 bytes, 33200 already pushed
		cli_pull_read_done: Requesting 2600 bytes at 1831960, position 0
		cli_pull_read_done: Pushing 0 bytes, 33200 already pushed
		cli_pull_read_done: Pushing 0 bytes, 33200 already pushed
		     1802240 ( 3437.5 kb/s) \\win98\\WIN98_67.CAB
		(3437.5 kb/s) (average 3180.11 kb/s)
		dos_clean_name [\\win98\\IN98_68.CAB]
		unix_clean_name [\\win98\\IN98_68.CAB]
		NT_STATUS_NO_SUCH_FILE opening remote file \\win98\\IN98_68.CAB (\\win98\\)
		lang_tdb_init: /usr/lib64/samba/en_US.UTF-8.msg: No such file or directory
		strlen(cur_dir)=1, strlen(finfo->name)=7
		Writing a dir, Name = \\Century\\
		WriteTarHdr, Type = 5, Size= 0, Name = \\Century\\
		                directory \\Century\\
		Doing list with mtar_mask: \\Century\\*
		num_setup=1, max_setup=0, param_total=23, this_param=23, max_param=10, data_total=0, this_data=0, max_data=2920, param_offset=68, param_pad=0, param_disp=0, data_offset=94, data_pad=3, data_disp=0
		strlen(cur_dir)=9, strlen(finfo->name)=0[/CODE]

Then this does not stop the screen would fill ‘\\\\\\\\\\\\\\\\\\\’
The file ‘\win98\IN98_68.CAB’ not called ‘IN98_68.CAB’, this is called WIN98_68.CAB, neither is not the last of the \win98 so it should not change directory to \Century

This does not happen in all windws98, neither happened before upgrading to SP3 (previously had SP1) so it ends up being something associated files of each client.

Accessing with smbclient command line via the WIN98_68.CAB file is displayed with the name IN98_68.CAB, but ‘get WIN98_68.CAB’ download the file correctly.

It may be that Samba 3.6.3 is not compatible with win98?


well, I’m almost abandon …
I found a directory that does not show the ‘.’ (dot) in the current directory.

smb: \\> pwd Current directory is \\\\pc-01\\PROGRAMA\\ smb: \\> ls D 0 Wed Aug 25 17:42:58 2010 .. D 0 Wed Aug 25 17:42:58 2010 ARMAST16.EXE 41888 Fri Mar 10 09:31:24 2000 DARIO.EXE 101984 Tue Dec 14 19:17:06 2004

above the ‘…’ should be the ‘.’
When I try backing up this directory fails to start, unable to make backup of any file.

This error could not be produced by the charset …