Upgrade path from 0.4.5 to 0.5?

Continuing the discussion from RancherOS Release - v0.5.0:

So what is the recommend way to upgrade 0.4.5 to 0.5?

We still recommend upgrading using sudo ros os upgrade.

Hi @denise,

I tried to update with ros OS upgrade. Installation / consols is broken and I have no access.

Hohe to fix that issue?

I would need more details on your setup to be able help you.

How/where did you set up your instance? Did you just do a sudo ros os upgrade? What happened after?

What version did you have before?

It’s a APU with RancherOS 0.4.5 installed from ISO. It wasn’t prod so I used for upgrade test. Upgraded by “ros os upgrade” to 0.5.0.
No login SSH login prompt after upgrade. Host isn’t active in Rancher Server.
How could I recover it? Vor is a New install / reset needed?

Other instances (vmware and kvm VMs) running 0.4.5 and should be Upgrades to 0.5.0, but waiting for upgrade instructions. Rancher Server running in the VMware instance.

Any update here?
How to repair / upgrade 0.4.5 to 0.5 RancherOS?

Have you tried rebooting to see if that resolves your issue? We’ve had someone else hit a similar SSH issue in AWS, but when they rebooted, they were able to ssh in.

Thanks, deactivated the host since my post here. Restarted it today and it boots up as it should…

I have to upgrade two more hosts from 0.4.5 to 0.5.
So I just have to reboot / reset it some times until it will boot up again…?

@pwFoo Yes, if you have a ssh issue, then rebooting should fix the issue.

There seems to be a docker issue that we need to investigate. If you have access to the console and can provide logs when you are unable to ssh in, please provide them so we can troubleshoot further.

RancherOS is SSH with pubkey only. So no chance to login without console / ssh running.

I’ve had a similar problem, but was unable to solve with several reboots. I’m still running on 0.4.5. :sob: