vCenter error creating cluster 'name already exists'

Hi all, I am new to Rancher and I have installed 2.4.2 and have selected to use a vCenter Node Template for a new cluster build and in that template I use the “Data Center : Template” option for an existing template that resides in VCenter.

Each time I try to create a cluster I get the error message that the name of the Nodes already exist even process creates the VM node but fails on the configuration stage.

I have tried countless node name and they don’t prior exist each time

i will inc a screen shot.

Has anyone seen this pls?

Screenshot 2020-04-08 at 19.39.20

I am running into the same thing. This is because, from Rancher’s point of view, the node has not been successfully provisioned. It has tried to delete the node, but failed (I see the failed machine deletions in my logs), however it doesn’t seem to handle the failed delete. So it then tries to spin up a new node with the same name and vSphere doesn’t allow that of course.

The vSphere provisioner in 2.4.3 is extremely unreliable at best. If I attempt to provision the same cluster 10 times, it will work once or twice. There appear to be some issues with mounting the cloud-config (user-data.iso) files reliably in a DRS cluster and there is poor handling of deletions…e.g. Rancher will attempt to delete a cloud-config ISO even though it is still mounted by one of the provisioned VMs. Hopefully this will get fixed soon.