vSphere node folder never found when creating cluster

I’m trying to create a vSphere cluster.

In my node template, for the field Folder " Folder for the VM. This folder must already exist in the datacenter."

I entered: /rancher

But I always receive this message:

[node-controller] failed with : Error with pre-create check: “folder ‘/ha-datacenter/vm/rancher’ not found”

I tried on my datastore1 to create the /rancher folder and I also tried to create /ha-datacenter/vm/rancher but nothing worked.

Am I missing something ?


I left the field blank and now it works. I’m not sure I understand how this field works.

Thank you very much, apparently leaving it blank was the answer… Why didn’t I think of that…

It took me a while tool :slight_smile:

What is the configuration if we have to add a specific folder???

We have the same problem. On Rancher 2.3.3 I’m able to choose folder, but it always fails.

Error with pre-create check: “folder ‘/DCAMS-AM4/vm/NL/DCAMS-AM4/vm/stage’ not found”

It looks like rancher adds /vm/ in path. There is no such directory.

Having the same issue on 2.3.3. Choosing no folder will work but its a pain to move all the worker nodes if a node template is changed to a folder manually.

Hi Everyone, the folder targeting was a bug in 2.3.3 and this was fixed started 2.3.4 RC5 and even better now in RC8. If you can’t use an RC in your environment just know when 2.3.4 is officially out you should upgrade.

Related Issues