App Gitlab from Catalog stuck after upgrade: "Failed to install app gitlab. Error: UPGRADE FAILED: transport is closing"

We tried to upgrade our Gitlab App installation from 1.9.3 to 2.0.0. This failed because the upgrade path was not supported.
To fix this we tried upgrading to 1.9.4 first. This also failed with error ‘Failed to install app gitlab. Error: UPGRADE FAILED: transport is closing’
Doing a rollback to 1.9.3 gives the same error.
The state of the app stays in the ‘installing’ state.

1 Like

Hi, just checking: is this from you as well:
https://gitlab.com/gitlab-org/gitlab-ce/issues/63864

Yes,
my colleague opened that issue last week

The topic was moved to a new one:

Since the suggestion was made that the error comes from Helm/Tiller and not from the chart, we thought that it might be related to the installation trough Rancher rather than the chart itself.
Which is why we also opened a topic on the Rancher forum.