Blue Tooth - recognize new device

SLE handle blue tooth devices very well. It is easy to connect. But it is difficult to get the sound devices recognized in the Sound System.
I do have JBL earphones.

  • run via plug: no problem
  • run via blue tooth, random success. Often it takes a reboot or long time to get the earphones recognized.

What release of SLED is this? Is the bluetooth receiver device a dongle or part of the wifi card?

su -
hwinfo --bluetooth

Hi Malcom,
it’s a build in device, part of wifi card

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 138a:0050 Validity Sensors, Inc. Swipe Fingerprint Sensor
Bus 001 Device 008: ID 0b97:7772 O2 Micro, Inc. OZ776 CCID Smartcard Reader
Bus 001 Device 006: ID 0b97:7761 O2 Micro, Inc. Oz776 1.1 Hub
Bus 001 Device 013: ID 8087:0a2b Intel Corp. 
Bus 001 Device 004: ID 1199:9041 Sierra Wireless, Inc. 
Bus 001 Device 003: ID 056a:014f Wacom Co., Ltd 
Bus 001 Device 002: ID 04f3:2268 Elan Microelectronics Corp. 
Bus 001 Device 009: ID 0bda:5783 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

linuxSLED:/home/hans-christoph # hwinfo --bluetooth
04: USB 00.0: 11500 Bluetooth Device

  [Created at usb.122]
  Unique ID: X7GA.GS0ueMFUyi1
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.0
  SysFS BusID: 1-7:1.0
  Hardware Class: bluetooth
  Model: "Intel Bluetooth Device"
  Hotplug: USB
  Vendor: usb 0x8087 "Intel Corp."
  Device: usb 0x0a2b 
  Revision: "0.01"
  Driver: "btusb"
  Driver Modules: "btusb"
  Speed: 12 Mbps
  Module Alias: "usb:v8087p0A2Bd0001dcE0dsc01dp01icE0isc01ip01in00"
  Driver Info #0:
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #6 (Hub)

The point is the blue tooth get activated fine. But the sound doesn’t get activated as well.

Ahh ok, if you go into the Settings → Sound you can select in the dropdown to the bluetooth headset device and it’s working?
Also what version of SLED?

Hi Malcom.
I use SLED 15.1 - always updated. I know, I need to select the sound module I wish to use as speaker or headphones or Blue Tooth. But, the blue tooth headphones don’t get visible below sounds.
I have a Logitec BT adapter. This one is always visible and just work.
But my JBL Live500BT headset is only very few time visible in Sound. I get it on Bluetooth, but not sound.

So in settings if you run the sound test does this work?

Can you run;

aplay -l

From the list identify the bluetooth device and with it’s card and sub device reference can you try;

aplay -c 2 -D plughw:{device#},{subdevice#} /usr/share/sounds/alsa/Front_Right.wav
aplay -c 2 -D plughw:0,3 /usr/share/sounds/alsa/Front_Right.wav

I get those devices:
The Blue tooth device is running and connected right now.

linuxSLED:/home/hans-christoph # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
But what is the right device here?
I tried it just for one:
linuxSLED:/home/hans-christoph # aplay -c 2 -D plughw:{3},{0} /usr/share/sounds/alsa/Front_Right.wav
ALSA lib conf.c:1876:(snd_config_load1) toplevel:1:2:Unexpected char
ALSA lib conf.c:5017:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2552:(snd_pcm_open_noupdate) Unknown PCM plughw:{3},{0}
aplay: main:828: audio open error: Invalid argument
linuxSLED:/home/hans-christoph #
Didn’t work.

Picture: you can see, 2 devices are connected.

But the sound do not recognize the JBL. There might be an issue since the JBL Live is very new and there might be an issue with codecs or so. But I got it to work once like: keep blue tooth on on boot, try many times…

It could be related to the device age, I have a BT Intel Mini Mushroom an it connects fine.

What is the Logitech one in your list? Is this a connected keyboard or a mouse?

As root user if you run bluetoothctl can you list, pair get info from the device?


[NEW] Controller B8:81:xx:xx:xx:xx big-bird [default]
[NEW] Device 58:51:xx:xx:xx:xx Mini Mushroom
Agent registered
[Mini Mushroom]# info
Device 58:51:xx:xx:xx:xx (public)
	Name: Mini Mushroom
	Alias: Mini Mushroom
	Class: 0x00240404
	Icon: audio-card
	Paired: yes
	Trusted: no
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
	RSSI: -50
[Mini Mushroom]# exit
Agent unregistered
[DEL] Controller B8:81:xx:xx:xx:xx big-bird [default]

I get this:
linuxSLED:/home/hans-christoph # bluetoothctl

[NEW] Controller A4:34:D9:D7:ED:75 linuxSLED.hcpi.hq [default]
[NEW] Device 68:4A:4A:F3:AA:CE JBL LIVE500BT-LE
[NEW] Device 74:5B:C5:73:77:20 JBL LIVE500BT
[NEW] Device 88:C6:26:A9:77:C7 Logitech BT Adapter
Agent registered
And, funny, right now it get registred correct.

The Logitec is an older device connected to the HIFi system so I can play music over the HiFi Speaker.
The JBL is a brand new head set. Maybe this is the problem?

And if you remove that Logitch device so it’s just the headset, does that help?

No, this is funny, the Logitec get removed automatically somehow.
I tried to remove it actively (stopped it). But this was not a solution.
Right now, the headset is on always.

As you suspected, I also wonder on versions;

So for your setup the HCI version needs to be 8 for your 4.2 device… Unfortunately bluez-test is not in SLE, can only check on Tumbleweed… Perhaps boot a live USB of Tumbleweed (and install bluez-test)?

My test device is;

/sbin/lspci -nnk |grep BT
Intel WLAN 3165NGWG Stone Peak 1 ac 1x1 + BT 4 LE PCIe+USB+NGFF_2230 WW

btmgmt info
Index list with 1 item
hci0:	Primary controller
	addr 84:.... version 8 manufacturer 2 class 0x000000

So my device is version 8, so meets the 4.2 requirement.

the JBL headset has bluetooth version 4.2
Bluetooth-profiles HFP v1.6, A2DP V1.3, AVRCP V1.5
Bluetooth send-modulation GFSK, x001A/4DQPSK, 8DPSK
But my device I need to search for what version it use.