Help with VMware again! Wont start a virtual machine? vmmon

Hello SUSE community!
So I managed to get VMware Workstation 16 player installed. I set up a windows10.iso and got everything set up. Then I ran into this issue where it says"Could not open /dev/vmmon: No such file or directory.
Please make sure that the kernel module `vmmon’ is loaded."
, then “Failed. I tried to check out the version with vmware -v and it wouldn’t tell me so I just changed the command with what the gui about option said. I also have tried other commands to look up vmware version which didnt work either.o initialize monitor device.” Then it just shuts down immediatley? I have loaded a few commands in the command line such as “wget . Then…tar -xzf workstation-16.0.0.tar.gzcd vmware-host-modules-workstation-16.0.0…tar -cf vmmon.tar vmmon-only
tar -cf vmnet.tar vmnet-onlysudo cp -v vmmon.tar vmnet.tar /usr/lib/vmware/modules/source/finally sudo vmware-modconfig --console --install-all. It looks like it wants to start but then shuts down. I checked these files in the /usr/lib/vmware/modules/source directory and the vmmon and vmnet .tar are there. Just need some help please and thanks.

Hey guys so just an update! I didn’t enter the commands properly nor did I change to root with sudo su before I copied in the root directory. Also I did the modconfig install all command at the end separately and it worked. Just in case anyone needs help let me know. Iv also got Windows 10 installing and its going smoothly so far. If anyone needs help with that too ill be here. Linux is something else for sure, but I Love learning more about this!