Is_default not respected

In my cluster.yml, I set private_registries[0].is_default to true, but it seems that rke is not using the private registry while pulling system images, and the installation fails eventually with an error saying that some system images can not be pulled.

To work around that, I have to add the registry url to “” manually.