Please call mgr-sync refresh.

Hello all,
my recent problem: disconnected setup (smt + suma 3.2), works without problems. But SLES15-SP2-repos can not be added to suma. They are mirrored in smt, double checked this. They are listed on suma via mgr-sync list [products|product|channels], but can not be added to suma. Error message is:

mgr-sync add product
Enter product number (1-34): 5
Adding recommended product ‘Basesystem Module 15 SP2 x86_64’
Adding recommended product ‘Server Applications Module 15 SP2 x86_64’
Adding recommended product ‘SUSE Manager Tools 15 x86_64’
Adding channels required by ‘SUSE Linux Enterprise Server 15 SP2 x86_64’ product
‘sle-product-sles15-sp2-updates-x86_64’ depends on channel ‘sle-product-sles15-sp2-pool-x86_64’ which has not been added yet
Going to add ‘sle-product-sles15-sp2-pool-x86_64’
General error: <Fault -1: ‘redstone.xmlrpc.XmlRpcFault: unhandled internal exception: Product Data refresh needed. Please call mgr-sync refresh.’>
Tried different add-options (products, channels), same result.
Checked any logfile, not found any really hint.
Any ideas?


more information: found out by sniffing that mgr-synch refresh does not write the 15-sp2 meta information into suma. Any other error builds up on that.
Exactly the same set of repositories are mirrored on the smt server as well for sp1 as for sp2. The recent product_tree.json file is there. There must be some reason why mgr-sync is ignoring nearly. Looking into the product_tree-json file things look the same for sp2/sp1 for the first view. Why does mgr-sync make a difference between sp1, sp2…
SUMA version is 3.2.15, since 3.2.14 the SUSE Linux Enterprise 15 SP2 family shall be supported.

@“” Hi and welcome to the Forum :slight_smile:

Sounds like a Support Request would be the best course of action to get it looked at.

Last trial worked: triggering vom INSIDE of SUMA via main organization Admin>Setup Wizard->SUSE Products worked. The Product where already listed there (dunno why, may be via SUMA update or via mgr-sync-tool even while pointing to an error), so ticking plus adding worked without error.
No idea what went wrong, but result is ok.