SUMA v4.2 Fresh install - Refreshing SUSE repositories fails

I’ve run into a perplexing issue with a fresh install of SUMA v4.2 (x86_64) - I got past one problem (#2 below) but ran into another issue (#1 below).

I’m installing SUMA in a network environment that requires a Proxy to reach the Internet - and the SUMA install requires it to talk to SCC during the install from DVD.

PROBLEM #1 (need help): After getting past Problem #2 below, I set up the SUMA normally, add the Organization Credentials. I go to sync everything. The sync for Channel Families succeeds. The sync for SUSE Products usually succeeds (occasionally may fail, but on the whole works).

However, Refreshing SUSE Repositories consistently FAILS. I can do it in the web UI, or using mgr-sync, no difference. In /var/log/rhn/mgr-sync.log the relevant entries are:

2021/02/26 08:15:31 -04:00 3726 mgr_sync/logger.debug(‘Invoking remote method synchronizeRepositories with auth_token ProperTokenHere’,)
2021/02/26 12:15:31 -04:00 3726 mgr_sync/logger.error(‘Refreshing SUSE repositories failed’,)
2021/02/26 12:15:31 -04:00 3726 mgr_sync/logger.error(‘Error: ProtocolError for suse.manager.fqdn:80/rpc/api: 500 Internal Server Error’,)

The same auth_token value works for the Channel Families and SUSE Products.

SUSE TS says the Org Credentials are correct/properly Entitled/etc. They say they are unable to reproduce the problem using the Org Credentials on their own test SUMA.

Instead, they seem to think it is the Proxy (it is an Artica appliance, which is squid under the covers, but doesn’t give us many knobs). However, from what I can tell, the Proxy is not rejected anything.

We can’t be the only ones running SUMA v4 in a controlled-access environment. Does anyone else have suggestions to offer?

PROBLEM #2 (has been solved): The SUMA Deployment Guide 7.4.4 provides a method to pass the Proxy information to the kernel when booting from the DVD. It seems to be wrong - at least for x86_64 using UEFI. Instead of adding the line shown, the parameter should be added to the list of parameters on the linuxefi line. I’ve started the process of asking for a documentation update.

RESOLUTION: This was tracked down to the upstream network provider. SUMA was working as designed.