Registration Code

Hello everyone,
I have created two trial systems, one with SLES 11 SP4 and another one with SLES 12 SP3, and I tried to register both systems with one free trial registration code that I generated this week on the customer center. My free trial code is from version 15 SP1 and I could successfully register SLES 12 SP3, but the SLES 11 SP4 gives the error “registration code invalid”.
Why does it register only SLES 12? If I take a look at “Base And Extensions Products” of my free trial subscription on the customer center page, it gives me a list of all SLES systems since SLES 10 up to SLES 15.
Can please anyone explain how does it works?

best regards

Hi and welcome to the Forum :slight_smile:
AFAIK the trial code will only allow one physical system to be registered and access to any one of the listed products. Is this the 60 day evaluation or the one year developer one? I think you can have both…

Dear Malcon,
Thank you for your reply…
This is a 60day evaluation key. I tried to register this virtual system first before any other machine and gives me the error “registration code invalid”.

If you log into your SCC (SUSE Customer Center) account, can you check if the registration code is in use by the other system, if so delete and try registering the new system again.


You connecting to the old system on Microfocus, if you use the command line to register? Is SUSEConnect present on the system? Else have a look here and see if this works;
I suspect you might be out of luck registering the old release…

Hi Malcon,
I found out what’s causing this error, SLES 11 uses old NCC Url to do the registration, I just updated the configuration file “/etc/suseRegister.conf” with the current working SCC url and my system was successfully registered.
This “problem” is related in this document:
Thank you very much for your efforts helping me with this thread.
Have a nice day,

Best regards,
Everton Weschenfelder