SLE end kernel panic - not syncing: No working init found. Try passing init= option to kernel

Hi All! I have SLE 15 SP3 SAP that cannot boot due to the error end kernel panic - not syncing: No working init found. Try passing init= option to kernel.

This happened after my zypper update online in SLE 15 SP3. I run offline upgrade from SLES 12 SP5 to SLE 15 SP3 successful but the yast and other apps is not updated so i run the zypper update online and apply the updates. After reboot it can’t boot now.

Appreciate your thoughts about this. Thanks in advance for helping me!

@M_A_T Hi and welcome to the Forum :smile:
It’s running btrfs and snapshots, so should be able to select a previous snapshot to boot from?

Hi @malcolmlewis1 this is for physical host

@M_A_T so when it boot’s at the GRUB menu, select advanced and should off to select a snapshot to boot from?

Hi @malcolmlewis1 I try select other version kernel in the advanced but same problem.

@M_A_T Almost sounds like grub wasn’t installed properly… Have a read here

Or has /boot filled up?

Yes @malcolmlewis1 i successfully shim-install
Also have problem when dracut or mkinitrd cannot proceed due to initrd missing


@M_A_T Run mkinitrd or dracut -f --regenerate-all

@malcolmlewis1 dracut module ‘initrd’ cannot be found same. Run commands: mkinitrd and dracut -f --regenerate-all

@M_A_T So /boot is not full? Your also booting from 000A, can you run efibootmgr -n 000B and then reboot, the -n just sets a one off boot from that entry. Also check the output from efibootmgr -v and make sure the entries all look ok.

Is it okay to run the efibootmgr -n 000B instead? Here is my efibootmgr -v list

@M_A_T See how the two different entries point to two different locations on /boot/efi/EFI do the shim.efi files exist in this location?

Do you have an option to reboot this system?

@malcolmlewis1 I will reboot the server and see then

Hi @malcolmlewis1 here’s what i’ve got


@M_A_T and if you reboot again (with the default) what does it show, the same sync error?

will set back efibootmgr -n 000A, for a while will reboot the server.

@M_A_T Also have a read here:

@malcolmlewis1 I revert the efibootmgr to 000A and the kernel panic still persisted

@M_A_T so what files are listed in the /boot directory?

@malcolmlewis1 here