SLE 15 cannot boot production down

I have a virtual machine in production that can no longer boot, I tried several tutorials on the internet but nothing

the host is ESXi 6.5
Suse enterprise linux 15 virtual machine
I tried to reinstall the grub with this support link:, in Rescue mode.
already in step “cat / mnt / etc / fstab” the system crashes
then if I skip this step and launch the command “grub-install --root-directory = / mnt / dev / sda” I get this error “-bash grub-instal: command not found”

I also tried this tutorial:
but the system crashes after this command “# chroot / mnt” with a dash that flashes at the bottom

please help me it is my production which is stopped

Hi and welcome to the Forum :slight_smile:
Seems to me grub is working since you were able to boot in rescue mode? Or did you boot from the install media?
Sounds like you may have a full disk with no tweaking of snapper and btrfs?
Can you post the output from;

snapper list
btrfs filesystem show /

thank you for reply
see the output
command not recognized

Seems to me grub is working since you were able to boot in rescue mode? YES

OK, can you boot to grub and select the advanced options and boot from a previous snapshot? It will be read-only, but that’s ok for the moment, can you confirm first?

We dont have snapshot
when i boot from install disk see scrennshoot

You are booting from the installer, select the first option Boot from Hard Disk it will load grub again (the one on the HDD)?

yes i booted from hard disk but i have this screnn more than 20 minutes

That is plymouth, press the esc key when you see the init loading text. At grub you can temporarily disable by pressing a key to stop the countdown. Then press e to edit, at the line with linux (or linuxefi) add the following after the quiet;


i dont know where i’ll put this command

It’s further down in the second screen shot you posted.

i added the i clic on F10
the reboot by is same issue
see below

So some AppArmor adjustments had been performed? It just sits there running? Can you try also adding apparmor=0 after the plymouth.enable=0 via editing grub at boot.

it seems that the last order that I have was not recorded, however I made “F10”


I also entered the grub, I launched the two commands
but I still have the message

Yes, at each boot you will need to add the string as it’s not saved (because can’t boot). So in the grub menu you get too, in the advanced options there is no chance to select a previous snapshot? In the options can you select failsafe to boot from?

even with snapshots, I have a timer of several minutes

When you say you have a timer of several minutes, does it come up now?
If not, can you go back to say the 2020-06-11 pre one and see how that one goes?

When you say you have a timer of several minutes, does it come up now? NO
with the 2020-06-11 the boot process is blocked on this step below more than 4 hours

Are there earlier snapshots to try booting from?