Issue adding host with virtualbox

Hi, i’m trying to add a host using vbox driver as a way of loading more hosts on my machine for testing…

I’m getting this error: exec: “VBoxManage”: executable file not found in $PATH

I’m running rancher-server in the vagrant setup (0.41)… I tried going into the rancher-server (vagrant ssh) but I dont think VBoxManage is installed there… anyways, I assume it would somehow talk to the host’s virtualbox? I’m a bit lost… has anyone gotten this to work?

What I did:
cloned rancher/rancher repo
ran “vagrant up”

(Rancher is working locally… I can access it, deploy containers etc… its a single-host so far…so I tried adding another one with custom/vbox) which is when I got the error.

Any idea where I need to put the path, and how to find the correct one? Is it add VBoxManage’s path to my Mac’s path? or somehow install it inside the rancher vagrant machine?

here is the API output of the errored host…:

I believe that would be a nice feature request, to let rancher/server be able to talk to a remote Virtualbox. I’ve not looked into it, but it ought to be doable :smile:

As it is now, rancher/server expects to find VBoxManage on the same host as where it is running, which only makes sense if you’ve managed to run rancher/server on your local machine (or a machine where you actually have virtualbox installed), which, unless I’m mistaken, won’t be the case when you run rancher/server in a container.

Thanks for clearing that up kaos! I’m not really sure abt the use of it that way… at least for me… But adding a way to add it to a remote virtualbox would be an idea for sure… or maybe a “Vagrantfile exporter”?

In my idea I just wanted to add some hosts to my local machine for testing… I’d then, obviously, replicate the stack and services to another cloud, for example…

So I thought the solution to this was to use Rancher UI (found on github as rancher/ui project) directly on OS X, instead of running rancher/server in a Docker container.

But it looks like the UI project doesn’t include the API, as I get this error on npm start

API Proxy GET to /v1/token
Proxy Error: on GET to /v1/token : { [Error: connect ECONNREFUSED]
syscall: ‘connect’ }
API Proxy GET to /v1/schemas?limit=1000
Proxy Error: on GET to /v1/schemas?limit=1000 : { [Error: connect ECONNREFUSED]
syscall: ‘connect’ }

@funkytaco, the UI needs a rancher server to talk to (i.e. cattle)… so you need to run that locally outside of any container as well…