SLES11SP3 does not start after first reboot

we are evaluating SLES11SP3 and face the following issue:
We are trying a fresh installation. The first step works perfectly, RAID controller and logical disk successfully recognized.
After first reboot, the machine cannot boot, just states nothing when trying to boot from harddisk and stops.

Problem narrowed down:
We have a disk bigger than 2 TB, so found the section in the SP3 release notes stating:
“Booting from Harddisks larger than 2 TiB in Non-UEFI Mode (with GPT) fails.”
There are three possible options that should solve the issue, we tried option 2:
“Use a separate /boot partition. This partition must be one of the first 3 partitions and end below the 2 TiB limit”.

We did so, but unfortunately this does not help.

With a SLES11SP2 fresh installation, everything works fine, with the same hardware and the same settings.

Any help appreciated.

If you boot with a CD and then print the fdisk output for the real hard
drive, what does it show? Something like ‘fdisk -l /dev/sda’ should do
it, I would think.

Also, do you even see the Grub screen? What, exactly, do you see on
bootup after the initial BIOS screen finishes doing its RAM and other
hardware checks?

Good luck.

Thanks for the reply.

Fdisk does not work as the harddisk id bigger than 2 TB, so used parted.

[table=“width: 500”]
[td]File system[/td]

partition 2 is mounted as /boot.

And, no, i do not see the boot loader (GRUB) loading:
When trying to boot from harddisk after POST, just nothing happens.
When starting from linux CD and choosing “boot installed system”, then it is saying “booting from harddisk” and stays there forever.

Think there is a buggy code in the SP3 which writes the boot loader not correctly - because SP2 does correctly.

This may or may not work since it is made for openSUSE, but since the
cause is similar and the distributions are so similar I’m hopeful:

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…

I am facing exactly the same issue which insyen has mentioned here… Even after struggling a lot i found nothing helpful.
I tried to Use Repair Tool option - “Install New Boot Loader” and then tried to load boot loader using option - “Boot Installed system”. It is displaying message “No Linux Root Partition Found” even though i have explicitly created root partition.

My Hard disk size is 1TB and i am also doing the fresh installation, everything gone proper but after installation it is not starting or either displaying Booth menu.

I have created new partitions this way

Device Size Type FS Type Mount Point Start end

/dev/sda 931.51GB ST1000DM003 0 121600
/dev/sda1 10.51GB win95 Fat32 LBA Fat /boot/init 0 1371
/dev/sda2 8GB Linux Swap Swap Swap 1371 2416
/dev/sda3 250GB Linux Native Ext3 / 2416 35050
/dev/sda4 250GB Linux Native Ext3 /FS001 35050 67088
/dev/sda5 212.99GB Linux Native Ext3 /FS002 67088 95491
/dev/sda6 200.01GB Linux Native Ext3 /FS003 95491 121600

But after first reboot when i rechecked my partition details then it shows columns as above except “Mount Point”… Mount point field is disabled… What exactly is happening?
I think thats why it is not able to find root partition for loading.

Awaiting your positive feedback.

@insyen: Are you getting the same thing which your installation?

Also please suggest me the partition which i have created in proper or not.